前期高点(通达信公式 副图 源码 测试图)

2019-09-04     陈文     炒股技巧

N:=60;
HXA1:=REF(HIGH,N)=HHV(HIGH,2*N+1);
HXB1:=FILTER(HXA1,N);
HXC1:=BACKSET(HXB1,N+1);
HXD1:=FILTER(HXC1,N);
HXA2:=REF(LOW,N)=LLV(LOW,2*N+1);
HXB2:=FILTER(HXA2,N);
HXC2:=BACKSET(HXB2,N+1);
HXD2:=FILTER(HXC2,N);
HXE1:=(REF(LLV(LOW,2*N),1)+REF(HHV(HIGH,2*N),1))/2;
HXE2:=(HIGH+LOW)/2;
HXH1:=(HXD1 AND NOT(HXD2 AND HXE1>=HXE2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
HXH2:=HXD1 AND NOT(HXD2 AND HXE1>=HXE2);
HXL1:=HXD2 AND NOT(HXD1 AND HXE1=HXE2);
HXX1:=REF(BARSLAST(HXH1),1)+1;
HXF1:=BACKSET(HXH1 AND COUNT(HXL1,HXX1)>0,LLVBARS(IF(HXL1,LOW,10000),HXX1));
HXG1:=HXF1>REF(HXF1,1);
HXI1:=BACKSET(HXG1,2);
HXLD:=HXI1>REF(HXI1,1);
HXL2:=HXLD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
HXX2:=REF(BARSLAST(HXL2),1)+1;
HXF2:=BACKSET(HXL2 AND COUNT(HXH2,HXX2)>0,HHVBARS(IF(HXH2,HIGH,0),HXX2));
HXG2:=HXF2>REF(HXF2,1);
HXI2:=BACKSET(HXG2,2);
HXHD:=HXI2>REF(HXI2,1);
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HXHD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HXHD),1)+2);
XX2:=WW2>REF(WW2,1);
WW3:=BACKSET(XX2,REF(BARSLAST(HXHD),2)+30);
XX3:=WW3>REF(WW3,1);
WW4:=BACKSET(XX3,REF(BARSLAST(HXHD),3)+50);
XX4:=WW4>REF(WW4,1);

前一高:REF(H,BARSLAST(VV2)),COLORBLUE,DOTLINE;
前二高:REF(H,BARSLAST(XX2)),COLORff00ff,DOTLINE;
前三高:REF(H,BARSLAST(XX3)),COLOR00ffff,DOTLINE;


   

华尔街股票学习网登载的内容版权属于华尔街股票学习网及/或相关版权所属人持有或所有。
粤ICP备09286809号-1号 Copyright 华尔街股票学习网www.soobbs.com All Rights Reserved