通达信公式 呼应涨停及选股

2019-09-04     王杨     炒股技巧

N:=20;
ZT:=IF(C/REF(C,1)>1.0975 AND C=H,1,-1);
TS:=BARSLAST(ZT=1);
TJ1:=O<=REF(O,REF(TS,1)+1) AND ZT=1 AND REF(TS,1)<=N AND C>=REF(O,REF(TS,1)+1) AND REF(TS,1)+1>=2;
TJ2:=O>=REF(O,REF(TS,1)+1) AND L<=REF(C,REF(TS,1)+1)*1.03 AND ZT=1 AND REF(TS,1)<=N AND C>=REF(C,REF(TS,1)+1) AND REF(TS,1)+1>=2;
TJ3:=O<=REF(C,REF(TS,1)+1)*1.05 AND ZT=1 AND C> REF(C,REF(TS,1)+1) AND REF(TS,1)<=N AND REF(TS,1)+1>=2;
呼应涨停:TJ1 OR TJ2 OR TJ3,NODRAW;
DRAWTEXT_FIX(呼应涨停<>10,0.12,0.05,2,'欢迎使用春秋作品 ')COLORRED;
STICKLINE( ZT>0,0,1,2,0 ),COLOR00FFFF;
二次涨停:EVERY(ZT>0,2),COLOR0066FF,NODRAW;
三级跳涨停:EVERY(ZT>0,3),COLORLIRED,NODRAW;
STICKLINE( EVERY(ZT>0,2),0,1,2,0 ),COLOR0066FF;
STICKLINE( EVERY(ZT>0,3),0,1,2,0 ),COLORLIRED;
STICKLINE(REF(C,1)/C>1.0975 AND C=L,0,1,2,0 ),COLORGREEN;
跌停:REF(C,1)/C>1.0975 AND C=L ,NODRAW,COLORGREEN;
STICKLINE( 呼应涨停>0,0,1,2,0 ),COLORRED;
{
选股公式:
N:=20;
ZT:=IF(C/REF(C,1)>1.0975 AND C=H,1,-1);
TS:=BARSLAST(ZT=1);
TJ1:=O<=REF(O,REF(TS,1)+1) AND ZT=1 AND REF(TS,1)<=N AND C>=REF(O,REF(TS,1)+1) AND REF(TS,1)+1>=3;
TJ2:=O>=REF(O,REF(TS,1)+1) AND L<=REF(C,REF(TS,1)+1)*1.03 AND ZT=1 AND REF(TS,1)<=N AND C>=REF(C,REF(TS,1)+1) AND REF(TS,1)+1>=3;
TJ3:=O<=REF(C,REF(TS,1)+1)*1.05 AND ZT=1 AND C> REF(C,REF(TS,1)+1) AND REF(TS,1)<=N AND REF(TS,1)+1>=3;
选股:(TJ1 OR TJ2 OR TJ3) AND (REF(TS,1)>N-5);
}

   

用户评论


华尔街股票学习网登载的内容版权属于华尔街股票学习网及/或相关版权所属人持有或所有。
粤ICP备09286809号-1号 Copyright 华尔街股票学习网www.soobbs.com All Rights Reserved